Thursday, September 16, 2010

Error in vSphere HA configuration after upgrading to vCenter 4.1

After upgrading to vCenter Server 4.1, when you run an ESXi 4.0 host on that vCenter Server inventory, you see these symptoms:
The ESXi host reconfigures successfully for HA, but immediately displays an error
In the Summary tab, you see the error:
HA agent on in cluster has an error: error while running health check script
The issue occurs because the management agents on the ESXi host are not upgraded properly.
To resolve this issue, you must manually remove and reinstall the agents.

To manually remove and reinstall the agents:
  • Right-click the ESXi host and click Disconnect. This disconnects the ESXi host from the VirtualCenter Inventory.
  • Log in to the ESXi host using the Tech Support mode. For more information, see Tech Support Mode for Emergency Support (1003677) article in VMware.
  • Run these commands to uninstall the vpxa and aam components from the ESXi host:

  • Right-click the ESXi host and click Connect. This re-installs the vpxa agent.
  • Add the host to the appropriate cluster. This re-installs the aam agent. 
For more details see this KB article from VMware

No comments:

Post a Comment